Forum der ControllerSpielwiese


 
Zurück zur Übersicht
Autor
Thema: Problem bei Makroaufzeichnung


Hallo zusammen,

ich habe folgendes Problem, und hoffe, jemand kann mir helfen.

Ich habe eine Formel geschrieben:

=WENNFEHLER(WENN(ODER(SVERWEIS(Y58;Versand!C:E;3;0)="D";SVERWEIS(Y58;Versand!C:E;3;0)="L");WENNFEHLER(RUNDEN(WENN(Daten!P58="V";WENN(K57="IMPB2";WENN((S57*T57)<=1;1;2,25);SVERWEIS(Daten!K57;Faktoren[#Alle];3;0))*Daten!Q58*$AR$7;Daten!AI58*Daten!M58*$AR$7*WENN(LINKS(Daten!K58;3)="MAR";SVERWEIS(Daten!K58;Faktoren[#Alle];3;0);1));2);0);0);0)

Sie funktioniert einwandfrei, wenn ich sie direkt in Excel eintrage. Wenn ich sie allerdings als Makro aufzeichne und dann laufen lasse, springt der Debugger an.

Aufgezeichnete Makroversion:
ActiveCell.FormulaR1C1 = _
"=IFERROR(IF(OR(VLOOKUP(RC[-19],Versand!C[-41]:C[-39],3,0)=""D"",VLOOKUP(RC[-19],Versand!C[-41]:C[-39],3,0)=""L""),IFERROR(ROUND(IF(Daten!RC[-28]=""V"",IF(R[-1]C[-33]=""IMPB2"",IF((R[-1]C[-25]*R[-1]C[-24])<=1,1,2.25),VLOOKUP(Daten!R[-1]C[-33],Faktoren[#All],3,0))*Daten!RC[-27]*R7C44,Daten!RC[-9]*Daten!RC[-31]*R7C44*IF(LEFT(Daten!RC[-33],3)=""MAR"",VLOOKUP(Daten!RC[-3" & _
"ren[#All],3,0),1)),2),0),0),0)"

Wenn ich aus der Makroversion den Part:
IF(RC[-33]=""IMPB2"",IF((RC[-25]*RC[-24])<=1,1,2.25),VLOOKUP(Daten!RC[-33],Faktoren[#All],3,0))

Herausnehme, läuft dieser einzeln auch im Makro. Ohne den Abschnitt:
IF(RC[-33]=""IMPB2"",IF((RC[-25]*RC[-24])<=1,1,2.25),

Läuft auch der restliche Code.

Ich hab leider keine Ahnung, wo das Problem liegt, und was ich tun könnte, hat jemand eine Idee?

Vielen Dank,

Jenny



Ich hab die Bruchstücke des Makros jetzt nochmal Schritt für Schritt, bzw. Zeichen für Zeichen verglichen und schlussendlich den Fehler gefunden.
Vielleicht gab es Probleme mit der Länge der Formel bei der Aufzeichnung des Makros.

Ich konnte es auf jeden Fall lösen.

Danke trotzdem.

VG Jenny



© 2001/2017 ControllerSpielwiese.de powered by Joachim Becker WebSolutions
Gerne können Sie bei uns werben.